Googol - Mise à jour

Quand STARTPAGE se met à utiliser un content-encoding en gzip sans prévenir, ça fait cafouiller Googol qui n'y retrouve plus ses petits regexes.

Heureusement, en ajoutant

curl_setopt($ch,CURLOPT_ENCODING , "gzip");

dans la méthode de curl, on répare tout...

ouf.

❝ 7 commentaires ❞

1  mehkera le

Cette modif est-elle appliqué au code sur github (il semblerait que non) ?
J'ai ouvert 2 issues : https://github.com/broncowdd/googol/issues
Je ne sais pas du tout si je suis le seul à avoir ses soucis avec googol ?

Merci pour googol.

 
2  Bronco le

Non, je n'ai pas eu le temps de pousser les modifs sur github: d'ailleurs, je pense laisser tomber github de façon générale, trop compliqué pour mon usage perso.
Par contre, il y a un lien en bas de page de googol (télécharger) qui te permet de récupérer la version courante.

 
3  jerry wham le

Merci coupain mais ça ne fonctionne pas. Après la mise à jour, je n'avais plus du tout de résultat. J'ai dû faire machine arrière.
Pour les images, ça ne fonctionne plus depuis... quasiment le début.

Je comprends tes réticences à utiliser github, mais il y a quand même l'avantage de la revue de code et le suivi de la résolution des erreurs (issues).

Si tu ne veux plus utiliser github, tourne toi vers une autre instance git (framagit tant qu'il est encore temps)...

 
4  Bronco le

Ben ça ne remarche pas que depuis aujourd'hui... Et pour les images, je l'ai encore utilisé hier sans souci... ?!

En fait c'est la procédure de Git qui m'ennuie profondément: trop compliqué pour ce que ça apporte pour moi

 
5  mehkera le

Ok merci pour le lien.
Perso un petit yunohost > gitea sur un petit vps , tranquille tout est chez moi.
Mais je comprend si tu as une aversion à git.

 
6  uman le

D’abord, merci pour cet outil que j'utilise depuis quelques années.
Je suis bloqué en version 3.0a car la V4 me donne : Fatal error: Default value for parameters with a class type hint can only be NULL in .../assets/php/class/Helium_language_class.php on line 88
Il y a quelque chose que je n'ai pas réussi à régler avec cette V3.0a : parfois le premier résultat affiché me donne : https://www.google.com/preferences?hl=fr
En plus certaines url ne sont pas encodés comme il faut et n'ouvrent rien : https://www.youtube.com/watch%3Fv%3DdbzQYKvlsQ0
A l'affichage, c'est bon, quand je passe la souris sur le lien, c'est bon, mais quand j'ouvre le lien, il est mal encodé.
As-tu une idée de l'origine du problème ?

 
7  Bronco le

Salut Uman,
Je corrige cette erreur de suite.
J'ai corrigé l'erreur d'encodage dans la v4.
Par contre, en ce moment, startpage me fait chmir car il se met à faire comme google: s'il y a trop de connexions venant de la même ip, il demande la réponse à un captcha...
Du coup, sur mon instance: plus aucun résultat...

Je vais ENCORE devoir ruser...
Je mets la correction en ligne et tu pourras la récupérer directement depuis googol.warriordudimanche.net

 

Fil RSS des commentaires de cet article

✍ Écrire un commentaire

Inutile de poster un commentaire à la con pour vous faire de la pub, ce sera filtré et dégagé direct...

Quelle est la cinquième lettre du mot tnnisl ?