Snippetvamp beta 1.0

Grâce aux nombreux retours des copains - yosko, Cornoualis, Nico27, Bajazet,  Knah-Tsaeb et l'indispensable Jerrywham (qui me fait un retour très pro avec conseils sur chaque version que je commit, big thanx !)  - Snippetvamp est devenu assez stable pour pouvoir être utilisé de façon plus sérieuse.


Depuis le dernier post, beaucoup de choses ont été ajoutées ou améliorées (ceux celui qui suivent suit mon fil touït sont est déjà au courant, mais bon):

  • un bookmarklet permet de typiak les snippets de la page où l'on se trouve: un clic et snippetvamp parse la page à la recherche des <pre>, <code> ou snippets embeded en iframe, les récupère et préremplit le formulaire. Si vous n'êtes pas loggué, une case mot de passe est ajoutée automatiquement afin d'éviter de multiplier les chargements et les clics.
  • une option d'alerte de mise à jour (débrayable via la config).
  • des options de backup, import et restauration de fichier dat...
  • corrections de bugs et optimisations diverses
  • meilleure gestion du cache

J'ai encore du vin sur la manche pain sur la planche pour améliorer certaines choses, notamment:

  • une liste déroulante pour sélectionner les thèmes highlight.js
  • un filtrage des tags en mode public (éviter d'afficher des tags de snippets privés)
  • sans doute de futurs bugs qui attendent leur heure, bien planqués, les lâches...

Le zip est sur le dépôt github 

 

A + les copains 

 

❝ 4 commentaires ❞

1  JeromeJ le

Moi je suis ton fil de touït :) mais je pense pas être le seul


J'ai encore du mal avec Github :/ (d'ailleurs t'as ptet vu une news dans mon shaarlink à ce propos )

 
2  Bajazet le

Il en faut peu pour être dans tes amis, autant qu'un "ajouter à mes amis" sur Facebook ;)
Bon je test cette beta, je vois déjà que le bug https n'est pas complètement corrigé, j'ouvre un ticket dédié. Et j'ai toujours le bug du cadenas privé :(

 
3  jerrywham le

@Bazajet : le cadenas s'affiche bien. Ce doit être ton cache qui ne se vide pas ou le fichier css qui n'est pas reconstruit. Je te propose de supprimer le fichier computed_snippetvamp.css dans le dossier theme. Ça devrait arranger les choses.


Pour le https, je ne pense pas que Bronco ait bossé dessus...

 
4  Bronco le

@Bajazet: c'est le propre des mecs de devenir copains à partir de presque rien
Et grâce à WDD et mes bouts de codes, j'ai pris des contacts réguliers avec des gens sympa, qui m'ont permis de me pencher sur des choses que j'ignorais et m'ont aidé par le temps qu'ils ont régulièrement pris pour commenter ce que je faisais...
C'est pas ça les copains ? Des gens avec qui on communique régulièrement et qui sont là pour t'aider et te faire progresser ? ;)


Sinon, pour le https, normalement, le simple fait de changer l'adresse du site dans la config devrait fonctionner, non ? (https à la place de http)... en tout cas, la modif est répercutée correctement sur toutes les adresses utilisées, puisque c'est toujours la variable de config qui est utilisée...
Il faut bien penser à vider le cache (je mettrai une option en ce sens dans la config ou en footer, je pense)
N'ayant jamais utilisé d'adresse https pour mes projets, il y a peut-être une chose ou deux que j'ignore, c'est aussi une éventualité à ne pas négliger ;)

 

Fil RSS des commentaires de cet article

✍ Écrire un commentaire

les commentaires relevant du SPAM seront filtrés et dégagés direct...

Quelle est le sixième caractère du mot padn1j3b ?